Ir para conteúdo


Foto

Problemas para utilizar emulador Android (Sencha Cmd)


  • Por favor, faça o login para responder
2 respostas neste tópico

#1 laecio

laecio

    Iniciante

  • Membros
  • Pip
  • 1 posts

Postado 23 September 2014 - 11:00

Estou iniciando com sencha touch, e fiz um app de exemplo para emular para Android e iOS (uso Mac). Segui os passos de acordo com a documentação.

Passos que segui:

1. sencha -sdk /path/to/Framework generate app MyApp /path/to/MyApp

2. Coloquei o trecho no arquivo app.json
"builds": {
    "native": {
        "packager": "phonegap",
        "phonegap" : {
            "config": {
                    "platform": "ios",
                    "id": "com.mydomain.MyApp",
                }
        }
    }
}
3. sencha app build native

4. sencha emulate native


Quando eu faço para iOS, o emulador é chamado e o app é exibido sem problemas. Quando faço para android (troco o campo 'platform' de iOS para android), o emulador não é chamado. E mesmo se eu der o start no emulador manualmente, ele não abre o app.

Gostaria de saber se alguém já passou por isso.

#2 ti10

ti10

    Novato

  • Membros
  • PipPip
  • 10 posts

Postado 07 October 2014 - 09:47

Você já deu uma olhada no parâmetro androidAPILevel do arquivo packager.json pra ver se é a mesma versão que você tem instalado do seu emulador? E no caso do Android é obrigatório que o emulador já esteja sendo executado antes de dar o build do projeto.

Outra coisa, ao invés do emulador do Android você pode usar o Ripple pelo próprio Chrome.

[]´s

#3 ti10

ti10

    Novato

  • Membros
  • PipPip
  • 10 posts

Postado 28 October 2014 - 15:25

Não sei se você já resolveu afinal o tópico é meio antigo, mas pode ajudar alguém no futuro então...

No Android o emulador já deve estar sendo executado antes de você dar o build, para o iOS ele chama automaticamente, no Android não.

[]´s




0 usuário(s) está(ão) lendo este tópico

0 membros, 0 visitantes, 0 membros anônimos