Ir para conteúdo


Foto

Erro ao rodar aplicação


Melhor Resposta thyagomuris , 19 May 2017 - 16:57

Oi Wemerson,

 

 

Eu descobri o problema por causa das suas perguntas. Na verdade eu não sabia que tinha que configurar, mas suas perguntas me ajudaram a pesquisar uma solução.

 

Caso alguém tenha o mesmo problema o meu era o seguinte

 

 

Quando eu tentava rodar o comando sencha app watch  dava o erro que mencionei.

 

Meu problema foi porque o arquivo sencha.cfg não tinha configurado a pasta do ext

 

 

ai eu adicionei a linha abaixo e resolvi o problema.

ext.dir=${workspace.dir}/ext
Visualizar todo o conteúdo do post


  • Por favor, faça o login para responder
2 respostas neste tópico

#1 thyagomuris

thyagomuris

    Member Avançado

  • Membros
  • PipPipPip
  • 226 posts
  • LocationRio de Janeiro

Postado 16 May 2017 - 12:31

Galera, 

 

Comecei um projeto meu em uma máquina e rodando de boa. Ai baixei para outro pc, instalei o sencha cmd e quando vou rodar, da o erro abaixo.

 

Sencha Cmd v6.2.1.29
[ERR] Cannot satisfy requirements for "ext"!
[INF]    The following versions are available:
[INF]       5.0.0.970 ( ... compatible back to 4.0)
[INF]       5.0.1.1255 ( ... compatible back to 4.0)
[INF]       5.1.0.107 ( ... compatible back to 4.0)
[INF]       5.1.1.451 ( ... compatible back to 4.0)
[INF]       6.0.0.640 ( ... compatible back to 6.0.0)
[ERR]    The following versions cannot be satisfied:
[ERR]       root: [email protected] (No matches!)
[ERR] Cannot resolve package requirements
 
 
Eu pesquisei bastante aqui na internet, mas não entendi ainda o porque do erro. Alguém tem ideia ou uma luz do que devo procurar?
 
 
Obrigado

 


Thyago Muris 


#2 Wemerson Januario

Wemerson Januario

    Administrador Ext JS Brasil

  • Administrators
  • 836 posts
  • LocationGoiânia - GO

Postado 16 May 2017 - 13:33

quando vai rodar o que? qual comando?

O sdk(pasta ext) está incluído na workspace?

Como está sua estrutura de diretório? printa ai!

Qual versão do CMD está instalado?

Qual versão do Ext JS está usando?


Wemerson Januario
http://wemersonjanuario.com.br
Twitter: @januariocoder

 

Treinamento e Consultoria Ext JS. Qualifique-se já!


#3 thyagomuris

thyagomuris

    Member Avançado

  • Membros
  • PipPipPip
  • 226 posts
  • LocationRio de Janeiro

Postado 19 May 2017 - 16:57   Melhor Resposta

Oi Wemerson,

 

 

Eu descobri o problema por causa das suas perguntas. Na verdade eu não sabia que tinha que configurar, mas suas perguntas me ajudaram a pesquisar uma solução.

 

Caso alguém tenha o mesmo problema o meu era o seguinte

 

 

Quando eu tentava rodar o comando sencha app watch  dava o erro que mencionei.

 

Meu problema foi porque o arquivo sencha.cfg não tinha configurado a pasta do ext

 

 

ai eu adicionei a linha abaixo e resolvi o problema.

ext.dir=${workspace.dir}/ext

  • Wemerson Januario curtiu isso

Thyago Muris 





0 usuário(s) está(ão) lendo este tópico

0 membros, 0 visitantes, 0 membros anônimos