Ir para conteúdo


Foto

Grid não carrega dados


Melhor Resposta gpand_utf , 23 October 2017 - 19:29

Resolvido

no fetch inseri o parametro FETCH_ASSOC, conforme abaixo.

 

$stmt->fetch(PDO::FETCH_ASSOC)

Visualizar todo o conteúdo do post


  • Por favor, faça o login para responder
1 resposta neste tópico

#1 gpand_utf

gpand_utf

    Iniciante

  • Membros
  • Pip
  • 7 posts

Postado 22 October 2017 - 16:33

Olá pessoal
 
Estou desenvolvendo um CRUD em EXTJ para apresentar no estagio do meu curso. 
Porém estou com um problema. O Grid nao esta carregando os dados que retornam pelo JSON.
 
o JSON retorna o seguinte: 
 
[[{"IDCLIENTE":"2","NOME":"Maria","ENDERECO":"Rua das Pedras","EMAIL":"[email protected]","CELULAR":"46999887766"},{"IDCLIENTE":"3","NOME":"Josiana","ENDERECO":"Rua das Rochas","EMAIL":"[email protected]","CELULAR":"469898976644"},{"IDCLIENTE":"4","NOME":"Marisa","ENDERECO":"Rua das Riolas","EMAIL":"[email protected]","CELULAR":"46988760099"},{"IDCLIENTE":"7","NOME":"Cariane","ENDERECO":"Rua Anchieta","EMAIL":"[email protected]","CELULAR":"46999887766"},{"IDCLIENTE":"10","NOME":"Cristiva","ENDERECO":"Rua das Aves","EMAIL":"[email protected]","CELULAR":"46999887766"}]]
 
 


#2 gpand_utf

gpand_utf

    Iniciante

  • Membros
  • Pip
  • 7 posts

Postado 23 October 2017 - 19:29   Melhor Resposta

Resolvido

no fetch inseri o parametro FETCH_ASSOC, conforme abaixo.

 

$stmt->fetch(PDO::FETCH_ASSOC)






0 usuário(s) está(ão) lendo este tópico

0 membros, 0 visitantes, 0 membros anônimos